症狀
當您連接到 Internet 服務提供商 (ISP) 來從郵局協定 3 (POP3) 伺服器上檢索郵件時,即使您已選擇了保存密碼,也不保存您的密碼。再次輸入正確的密碼也不能解決該問題。
原因
此問題是由以下一個或多個原因造成的:
您的 Outlook 配置檔或 Outlook Express 標識已損壞。
存在載入項或防病毒軟體衝突。
對於 Windows XP、Windows 2000 以及 Outlook 2003 或 Outlook 更早版本中的用戶帳戶,註冊表
包含的 Protected Storage System Provider 子項的資訊不正確。
解決方案
要解決此問題,請使用下列方法。第一種方法面向的是普通受眾,其中包括初級電腦用戶。使用其他方法則需要掌握更高級的電腦知識。
方法 1:創建新的 Outlook 配置檔或新的 Outlook Express 標識
如果使用的是 Outlook,則首先應嘗試創建新的 Outlook 配置檔;如果使用的是 Outlook Express,則首先應嘗試創建新的Outlook Express 標識。為此,請參見本文後面的“創建新的 Outlook 配置檔”或“創建新的 Outlook Express 標識”部分。
創建新的 Outlook 配置檔
創建一個新的 Outlook 配置檔,然後將其配置為使用已損壞的配置檔所使用的個人檔夾 (.pst) 文件。為此,請按照下列步驟操作:
1. 查找 .pst 文件
要查找配置檔使用的 .pst 檔,請根據您使用的 Outlook 版本執行下列步驟。
對於 Microsoft Office Outlook 2007
1. 啟動 Outlook。
2. 在“工具”功能表上,單擊“帳戶設置”。
3. 在“電子郵件”選項卡上,單擊您的電子郵件帳戶。
4. 在“帳戶設置”對話方塊中的“選定的電子郵件帳戶將新電子郵件傳送到以下位置”下,將顯示與電子郵件配置檔關聯的 .pst 檔的路徑和檔案名。例如,該路徑和檔案名可能類似於以下內容:
C:\Documents and Settings\ user_name \Local Settings\Application
Data\Microsoft\Outlook\Personal Folders(1).pst
5. 記下與您的電子郵件配置檔關聯的 .pst 檔的路徑和檔案名。
對於 Microsoft Office Outlook 2003 和 Microsoft Outlook 2002
1. 啟動 Outlook。
2. 在“工具”功能表上,單擊“選項”。
3. 在“郵件設置”選項卡上,單擊“資料檔案”。
4. 記下與您的電子郵件配置檔關聯的每個 .pst 檔的路徑和檔案名。例如,該路徑和檔案名可能類似於以下內容:
C:\Documents and Settings\ user_name \Local Settings\Application
Data\Microsoft\Outlook\Personal Folders(1).pst
2. 在 Outlook 中創建新的電子郵件配置檔
找到 .pst 檔後,即可在 Outlook 中創建新的電子郵件配置檔。為此,請按照下列步驟操作。
對於 Outlook 2007
1. 啟動 Outlook。
2. 在“工具”功能表上,單擊“帳戶設置”。
3. 單擊“電子郵件”選項卡,然後單擊“新建”。
4. 按照“添加新電子郵件帳戶”嚮導中的說明創建新帳戶。
注意:如果您沒有“添加新電子郵件帳戶”嚮導所需的帳戶資訊,請查看現有帳戶的設置。為此,請在“帳戶設置”對話方塊中的“電子郵件”選項卡上單擊該帳戶,然後單擊“更改”。記下“Internet 電子郵件設置”對話方塊中的每項設置。
如果您不知道您的電子郵件帳戶的密碼,請與您的 Internet 服務提供商 (ISP) 聯繫。另外,如果您的郵箱沒有與 ISP 關聯,請與郵箱所在伺服器的網路管理員聯繫,以獲得有關密碼的幫助。
對於 Outlook 2003 和 Outlook 2002
有關如何在 Outlook 2003 和 Outlook 2002 中創建新的電子郵件配置檔的更多資訊,請單擊下面的文章編號,以查看Microsoft 知識庫中相應的文章:
829918 (http://support.microsoft.com/kb/829918/) 如何在 Outlook 2003 中創建一個新的電子郵件配置檔
287072 (http://support.microsoft.com/kb/287072/) 如何在 Outlook 2002 中創建一個新的電子郵件配置檔
3. 將新配置檔配置為使用已損壞的配置檔所使用的 .pst 文件
當在 Outlook 中創建了新的配置檔後,請將其配置為使用已損壞的配置檔所使用的 .pst 文件。為此,請根據您使用的 Outlook 版本執行下列步驟。
對於 Outlook 2007
1. 啟動 Outlook。
2. 在“工具”功能表上,單擊“帳戶設置”。
3. 在“電子郵件”選項卡上,單擊您的電子郵件帳戶。
4. 在“帳戶設置”對話方塊的底部,單擊“選定的電子郵件帳戶將新電子郵件傳送到以下位置”下的“更改檔夾”。
5. 依次單擊“新建 Outlook 資料檔案”、“Office Outlook 個人檔夾檔”和“確定”。
6. 找到並單擊已損壞的配置檔使用的 .pst 檔,然後單擊“確定”。
對於 Outlook 2003 和 Outlook 2002
1. 啟動 Outlook。
2. 在“工具”功能表上,單擊“選項”。
3. 在“郵件設置”選項卡上,依次單擊“電子郵件帳戶”、“查看或更改現有電子郵件帳戶”和“下一步”。
4. 單擊“新建 Outlook 資料檔案”,再單擊“存儲類型”下的“個人檔夾檔(.pst)”,然後單擊“確定”。
5. 找到並單擊要使用的 .pst 檔,然後單擊“確定”兩次。
注意:如果要使用多個 .pst 檔,請對每個要用於新電子郵件配置檔的 .pst 檔重複步驟 4 和步驟 5。
6. 在“將新電子郵件投遞到下列位置”列表中,單擊“個人檔夾”,然後單擊“完成”。
7. 如果收到以下消息,請單擊“確定”:
您已經更改了電子郵件的默認投遞位置。這將更改“收件箱”、“日曆”和其他文件夾的位置。這些更改將在下次啟動 Outlook 時生效。
8. 在“檔”菜單上,單擊“退出”。
9. 啟動 Outlook。接下來,如果您收到以下消息,請單擊“是”以便將 Outlook 面板快捷方式更新為指向這些 .pst 文件:
The location that messages are delivered to has changed for this user
profile. To complete this operation, you may need to copy the contents of
the old Outlook folders to the new Outlook folders. For information about
how to complete the change of your mail delivery location, see Microsoft
Outlook Help. Some of the shortcuts on the Outlook Bar may no longer work.
Do you want Outlook to re-create your shortcuts
創建新的 Outlook Express 標識
要創建新的 Outlook Express 標識,請按照下列步驟操作:
1. 在 Outlook Express 中的“檔”功能表上,指向“標識”,然後單擊“添加新標識”。
或
2. 在“檔”功能表上,指向“標識”,單擊“管理標識”,然後單擊“新建”。隨即將打開“新標識”對話方塊。
3. 在“輸入姓名”框中,鍵入您的名稱。
4. 如果要為此標識設置密碼,請單擊以選中“需要密碼”核取方塊,然後單擊“確定”。
5. 在“添加的標識”對話方塊中單擊“是”。Outlook Express 將詢問是否要以新用戶身份登錄。如果單擊“是”,將提示您輸入有關Internet 連接的資訊。如果單擊“否”,則保留當前用戶的已登錄狀態。
高級疑難解答
下列方法需要具備更高級的電腦知識。如果您對高級疑難解答感到不解,可以尋求他人的幫助或與支持部門聯繫。有關如何與支援部門聯繫的資訊,請訪問下面的Microsoft 網站:
http://support.microsoft.com/gp/assistsupport
(http://support.microsoft.com/gp/assistsupport)
方法 2:在安全模式下啟動 Outlook
要在安全模式下啟動 Outlook,請根據您使用的 Windows 版本執行下列步驟。
對於 Windows Vista
1. 單擊“開始”,在“開始搜索”框中鍵入 outlook.exe /safe,然後按 Enter。
對於 Windows XP、Windows Server 2003 或 Windows 2000
1. 單擊“開始”,然後單擊“運行”。
2. 在“打開”框中,鍵入 outlook.exe /safe,然後單擊“確定”。
在安全模式下,Outlook 不會運行任何其他非 Microsoft 服務。如果 Outlook 可以在安全模式下正常運行,則說明問題可能是由用於Outlook 的第三方服務(例如,載入項、防病毒軟體或防火牆)導致的。在這種情況下,可能需要先與支援部門聯繫,以幫助確定該載入項或第三方服務,然後再與相應的供應商聯繫。有關如何與 Microsoft 客戶支援服務部門聯繫的資訊,請訪問下面的 Microsoft 網站:
http://support.microsoft.com/gp/assistsupport
(http://support.microsoft.com/gp/assistsupport)
要解決可能由 COM 載入項導致的問題,請禁用不經常使用的所有 COM 載入項。然後重新啟動 Outlook。如果這樣不能解決問題,請逐個禁用每個載入項。如果這也不能解決問題,請禁用所有載入項。 要禁用 COM 載入項,請根據您使用的 Outlook 版本執行下列步驟。
對於 Outlook 2007
要禁用 COM 載入項,請按照下列步驟操作:
1. 在 Outlook 2007 中的“工具”功能表上,單擊“信任中心”。
2. 單擊“載入項”,再單擊“管理”列表中的“COM 載入項”,然後單擊“轉到”。
3. 在“COM 載入項”對話方塊中,單擊以清除要禁用的所有 COM 載入項的核取方塊。
4. 禁用了載入項後,請單擊“確定”,然後重新啟動 Outlook。
對於 Outlook 2002 和 Outlook 2003
要禁用 COM 載入項,請按照下列步驟操作:
1. 在 Outlook 2002 或 Outlook 2003 中,單擊“工具”功能表,然後單擊“選項”。
2. 單擊“其他”選項卡,然後單擊“高級選項”。
3. 單擊“載入項管理器”。
4. 在“載入項管理器”對話方塊中,單擊以清除要禁用的所有 COM 載入項的核取方塊,然後單擊“確定”三次。
5. 重新啟動 Outlook。
重要說明:此部分、方法或任務包含有關如何修改註冊表的步驟。但是,註冊表修改不當可能會出現嚴重問題。因此,請一定嚴格按照下列步驟操作。為了獲得進一步保
護,請在修改註冊表之前對其進行備份。這樣就可以在出現問題時還原註冊表。有關如何備份和還原註冊表的更多資訊,請單擊下面的文章編號,以查看
Microsoft 知識庫中相應的文章:
322756 (http://support.microsoft.com/kb/322756/) 如何在 Windows XP 和 Windows
Vista 中備份和還原註冊表
以下解決方案只有在已經嘗試了所有其他相關的密碼故障排除方法之後才可使用。
方法 3:備份註冊表並從 Protected Storage System Provider 子項中刪除用戶帳戶資訊。然後,重新輸入密碼選項。
為此,請根據您使用的 Windows 版本執行下列步驟。
注意:此方法不適用於 Windows Vista 和 Outlook 2007。
對於 Windows XP
備份註冊表項
1. 單擊“開始”,然後單擊“運行”。
2. 在“打開”框中,鍵入 regedit,然後單擊“確定”。
3. 找到並單擊以下註冊表項:
HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider
4. 在“檔”菜單上,單擊“導出”。
5. 在“保存在”框中,選擇要將 .reg 檔保存到的位置。
6. 在“檔案名”框中,鍵入檔的名稱,然後單擊“保存”。
7. 在“檔”菜單上,單擊“退出”。
刪除用戶帳戶資訊
重要說明:請勿刪除主 Protected Storage System Provider 項。此項不會自動重新生成。如果您未遇到密碼保存問題,且忘記了密
碼,則刪除該用戶子項可能會導致無法檢索您的郵件。
注意:如果您是 Windows XP 用戶,則必須具有管理員許可權才能編輯系統註冊表。
1. 退出所有程式。
2. 單擊“開始”,單擊“運行”,在“打開”框中鍵入 regedit,然後單擊“確定”。
3. 3. 找到並單擊以下註冊表項:HKEY_CURRENT_USER\Software\Microsoft\Protected
Storage System Provider
4. 在“編輯”功能表上,單擊“許可權”。
5. 單擊當前已登錄用戶的註冊表項。然後,確保“讀取”和“完全控制”許可權均已設置為“允許”。
6. 單擊“高級”。然後,確保已選中了當前登錄用戶,“完全控制”已在“許可權”列中列出,並且“該項及其子項”已在“應用於”列中列出。
7. 單擊“用在此顯示的可以應用到子物件的專案替代所有子物件的許可權專案”核取方塊將其選中。
8. 單擊“應用”,然後單擊“是”繼續。
9. 單擊“確定”兩次。
10. 雙擊“Protected Storage System Provider”項將其展開。單擊 Protected Storage
System Provider 項下面的用戶子項檔夾,單擊“編輯”功能表上的“刪除”,然後在警告消息對話方塊中單擊“是”。
該用戶子項檔夾類似於以下示例:
S-1-5-21-124525095-708259637-1543119021-16701
注意:對於您擁有的每個身份,Protected Storage System Provider 項下均有一個子項。要在所有身份中解決此問題,必須刪除Protected Storage System Provider 項下的所有用戶子項檔夾。
11. 在“註冊表”菜單上,單擊“退出”。然後重新啟動電腦。
對於 Microsoft Windows 2000
如何備份註冊表
1. 單擊“開始”,然後單擊“運行”。
2. 在“打開”框中,鍵入 regedt32,然後單擊“確定”。
3. 找到並單擊以下註冊表項:
HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider
4. 在“註冊表”菜單上,單擊“保存項”。
5. 在“保存在”框中,選擇要將 .reg 檔保存到的位置。
6. 在“檔案名”框中,鍵入檔的名稱,然後單擊“保存”。
7. 在“註冊表”菜單上,單擊“退出”。
如何在註冊表中刪除用戶帳戶資訊。
重要說明:請勿刪除主 Protected Storage System Provider 項。此項不會自動重新生成。如果您未遇到密碼保存問題,且忘記了密碼,則刪除該用戶子項可能會導致無法檢索您的郵件。
注意:如果您是 Windows 2000 用戶,則必須具有管理員許可權才能編輯系統註冊表。
1. 退出所有程式。
2. 單擊“開始”,然後單擊“運行”。
3. 在“打開”框中,鍵入 regedt32,然後單擊“確定”。
4. 找到並單擊以下註冊表項:
HKEY_LOCAL_MACHINE\Software\Microsoft\Protected Storage System Provider
5. 在“安全”菜單上,單擊“許可權”。
6. 單擊當前已登錄用戶的註冊表項。然後,確保“讀取”和“完全控制”許可權均已設置為“允許”。
7. 單擊“高級”。然後,確保已選中了當前登錄用戶,“完全控制”已在“許可權”列中列出,並且“該項及其子項”已在“應用於”列中列出。
8. 單擊以選中“重置所有子物件的許可權並允許傳播可繼承權限”核取方塊。
9. 單擊“應用”,然後在系統提示繼續時,單擊“是”。
10. 單擊“確定”兩次。
11. 雙擊“Protected Storage System Provider”項將其展開。單擊 Protected Storage
System Provider 項下面的用戶子項檔夾,單擊“編輯”功能表上的“刪除”,然後在警告消息對話方塊中單擊“是”。
該用戶子項檔夾類似於以下示例:
S-1-5-21-124525095-708259637-1543119021-16701
注意:對於您擁有的每個身份, Protected Storage System Provider 項下均有一個子項。要在所有身份中解決此問題,必須刪除Protected Storage System Provider 項下的所有用戶子項檔夾。
12. 在“註冊表”功能表上,單擊“退出”,然後重新啟動電腦。
如何在 Outlook 2002 和 Outlook 2003 中重新輸入密碼
1. 單擊“開始”,指向“設置”,然後單擊“控制面板”。
注意:在 Windows XP 中,單擊“開始”,然後單擊“控制面板”。
2. 雙擊“郵件”圖示或“郵件和傳真”圖示。
3. 單擊“顯示配置檔”,單擊您正在進行故障排除的帳戶,然後單擊“屬性”。
4. 單擊“電子郵件帳戶”。
5. 請確認已選中“查看或更改現有電子郵件帳戶”核取方塊,然後單擊“下一步”。
6. 在“電子郵件帳戶”對話方塊中,單擊您正在進行排查其故障的帳戶,然後單擊“更改”。
7. 在“登錄資訊”下,輸入密碼,然後單擊“記住密碼”核取方塊將其選中。
8. 單擊“下一步”,然後單擊“完成”。
9. 啟動 Outlook。
10. 使用“發送和接收”命令確定是否已保存了密碼。
如何在 Outlook 2000 企業或工作組 (CW) 中重新輸入密碼
1. 單擊“開始”,指向“設置”,然後單擊“控制面板”。
注意:在 Windows XP 中,單擊“開始”,然後單擊“控制面板”。
2. 雙擊“郵件”圖示或“郵件和傳真”圖示。
3. 在服務列表中單擊“Internet 電子郵件”將其選中,然後單擊“屬性”。
4. 在“伺服器”選項卡上,輸入密碼,單擊“記住密碼”核取方塊將其選中。
5. 單擊“應用”,然後單擊“確定”。
6. 啟動 Outlook。
7. 在“工具”功能表上,單擊“發送和接收”確定是否已保存了密碼。
如何在 Outlook Express 中保存密碼
1. 啟動 Outlook Express。
注意:如果收到登錄錯誤,請關閉該對話方塊並繼續。
2. 單擊“工具”,然後單擊“帳戶”。
3. 單擊“Internet 帳戶”視窗中的“郵件”選項卡。
4. 在“帳戶”列中,單擊要更改的 Internet 電子郵件帳戶將其選中,然後單擊“屬性”。
5. 在“伺服器”選項卡上,在“密碼”框中鍵入密碼,然後單擊“記住密碼”核取方塊將其選中。
6. 單擊“確定”,然後單擊“關閉”。
7. 退出 Outlook Express,然後重新啟動。
8. 在“工具”功能表上,單擊“發送和接收”確定是否已保存了密碼。
注意:如果其他 Windows 2000 或 Windows XP 用戶遇到密碼保存的問題,請重新輸入密碼,然後單擊那些配置檔的“記住密碼”核取方塊將其選中。每個用戶可能都需要登錄以讓其密碼得到保存。
這篇文章中的資訊適用於:
Microsoft Office Outlook 2007
Microsoft Office Outlook 2003
Microsoft Outlook 2002 標準版
Microsoft Outlook 2000 標準版
Microsoft Outlook Express 6.0 |